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Overview

● working with collections
○ enhancing access
○ long-term preservation

● working with digital audio  -- Audacity
○ audio capture (digitization)
○ audio editing

● metadata
● transcription and translation -- SayMore
● recording – MukurtuMobile
● dictionary making – LexiquePro



Goal of this workshop

● Introduce the field of digital language archiving

● Provide an overview of resources available for 
working with Native language materials
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Language Documentation



Documentation → Revitalization



Working with collections

● creating appropriate linguistic metadata 
descriptions

● acquiring and working with digital audio/video

● linking text and audio/video 

● transcription and translation

● enhancing access through creation of websites, 
mobile apps and interactive resources



Digital language archiving as a field

● Open Language Archives Community (OLAC), 2001

● Digital Endangered Languages and Musics 
Archiving Network (DELAMAN), 2003

● Electronic Meta-structures for Endangered 
Languages Data (E‑MELD), 2005



Digitization ≠ Preservation
Digitization is the process of transforming analog 

material into binary electronic (digital) form, especially 
for storage and use in a computer. 

Preservation is the professional discipline of protecting 
materials by minimizing chemical and physical 
deterioration and damage to minimize the loss of 
information and to extend the life of cultural property. 

(definitions from the Society of American Archivists)

Digitization alone will not ensure preservation without a 
long-term strategy and commitment to digital 
preservation. 



Backup ≠ Archiving
● A robust data backup and storage strategy should be part 

of your Data Management Plan

● However, backing up data is not the same as archiving

○ your hard drive is not an archive (even if you have lots 
of copies)

○ an archive provides an institutional commitment to 
long-term preservation



Digital Preservation
Best practice recommendation is to use a Digital Mass 

Storage System (DMSS).

Guidelines from International Association of Sound and 
Audiovisual Archives (IASA)

http://www.iasa-web.org/tc04/audio-preservation

Requires an institutional commitmente

http://www.iasa-web.org/tc04/audio-preservation


Open-reel recordings
● Long life-span (> 40 yrs)

● Should be stored vertically

● Equipment increasingly difficult to find and maintain

● Try to use “play once” strategy, as older recordings may 
deteriorate during playback

● Speeds may not match; this can be adjusted by changing 
sample rate after transfer

● Proper setup (e.g., tape alignment) is critical to 
successful transfer

● Consider contracting with professional



Audio cassette recordings

● Shorter lifespan

● More fragile than open reel

● Equipment still widely available, but be sure to test 
prior to using with valuable recordings

● Never use fast-forward/rewind

● Try to use “play once” strategy, as older recordings 
may deteriorate during playback



Vinyl discs

Equipment fairly easy to find due to resurgence in 
collectors market



Optical Media (CD/DVD)
"The CD was initially marketed as the perfect permanent 

carrier, but this was soon shown not to be the case when 
many of the early discs failed. Even though subsequent 
technological development has improved on many of the 
early manufacturing faults, no credible claim can be 
made to permanence."

"... the risk of failure of a storage system based on this type 
technology is high when compared to other approaches."

"Initial investigations indicate that recordable CDs do not 
necessarily proceed to failure in a linear way and that as 
a consequence small change in initial error rates could 
have a greater effect on useful life of the disc.” 

(Bradley 2009)



Optical Media (CD/DVD)

● Recommend transfer to Digital Mass Storage System 
(DMSS)

● Types of CD
○ data CD (regular computer files)

○ audio CD (special .cda files for CD player)

● Audio CD files



Extracting audio files from CD

● For “data disc” 
simply open CD and 
copy

● For “audio disc” use 
extraction software, 
e.g., iTunes
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Extracting audio files from CD
● For “data disc” simply 

open CD and copy

● For “audio disc” use 
extraction software, e.g., 
iTunes

● Following import 
choose “reveal in 
Finder” to find the 
extracted .wav file. 



Digital best practice

● language archives and language documenters were 
forced to grapple with digital preservation early, due 
to: 
○ looming obsolescence of media formats

○ vast amounts of born digital data being produced by 
language documentation programs (and resulting risk 
of “digital carnage” in which data become effectively 
inaccessible)



Text standards

● store documents as plain text or images

● use Unicode font encoding
○ describes characters based on their meanings rather 

than their appearance

■ ł

■ LATIN SMALL LETTER L WITH STROKE

■ Unicode: U+0142



Text standards

always use unicode



Recording standards

● Ideally, all audio should be recorded as 
uncompressed, linear PCM (e.g., .wav, .aif files)

● 96 kHz / 24 bit 

● Lossy compression (.mp3, .m4a) cannot capture the 
full dynamic range of Native language, particularly 
“creaky” voice and glottalized sounds

● Compressed audio should be converted to linear 
PCM for archiving; however, the original recording 
format should be identified in the metadata



Metadata for language documentation
● Open Language Archives Community (OLAC)

○ http://language-archives.org
● ISLE MetaData Initiative (IMDI)

○ http://www.mpi.nl/IMDI/
● AILLA Metadata

○ http://www.ailla.utexas.org/site/metadata.html
● A Gentle Introduction to Metadata by Jeff Good

○ http://linguistics.berkeley.
edu/~jcgood/bifocal/GentleMetadata.html

● Metadata in Language Documentation and Description
○ http://www.hrelp.org/events/external/lsa2011/

http://language-archives.org
http://language-archives.org
http://www.mpi.nl/IMDI/
http://www.mpi.nl/IMDI/
http://www.ailla.utexas.org/site/metadata.html
http://www.ailla.utexas.org/site/metadata.html
http://linguistics.berkeley.edu/~jcgood/bifocal/GentleMetadata.html
http://linguistics.berkeley.edu/~jcgood/bifocal/GentleMetadata.html
http://linguistics.berkeley.edu/~jcgood/bifocal/GentleMetadata.html
http://www.hrelp.org/events/external/lsa2011/
http://www.hrelp.org/events/external/lsa2011/


Minimal descriptive metadata

● Date

● Location

● Subject language (use ISO 639-3 codes)

● Contributors (participants)

● Contributor bios
○ age, gender, languages, parents’ languages







Preservation vs. Presentation

● First take care of preservation; 

● then make flashy, pretty products.



Rights management

● Open access ≠ free use

● Concerns about access are often really concerns 
about use

● Usage is governed by license agreements and is 
independent of access

● Many language archives make use of Creative 
Commons license (creativecommons.org):
○ Attribution-NonCommercial-ShareAlike (CC BY-NC-

SA)

○ Attribution-NonCommercial-NoDerivs (CC BY-NC-
ND)



Access restrictions

● usage-based
○ non-commercial use (this takes care of 99%)

● member-based
○ tribal members

○ family members

○ research/education project members

● Be sure that conditions for access are easily 
operationalizable

● Think about what a 22nd century archivist will need 
to know in order to implement the restrictions



Recording on mobile devices

● Some of the best language documentation is being 
done by kids with iPhones

● While iPhone recording is not recommended best 
practice, it can be made better

● use an app which records uncompressed audio 
(WavePad)

● file naming conventions

● regular backup / download of recordings



Recording on mobile devices



Recording on mobile devices



Using Audacity to open
and edit audio files

↗ Audacity is free, open source software for both 
Windows and Mac computers that edits and 
records audio. 

↗ Free download: http://audacityteam.org/ 

↗ In this course, we will use Audacity to perform basic 
editing and conversion of digital recordings. 

■sample clip & transcription at 
http://tinyurl.com/atalm2015-sampleclip

http://tinyurl.com/atalm2015-sampleclip
http://tinyurl.com/atalm2015-sampleclip


Opening files

↗ To open an existing recording in Audacity, select 
“Open...” from the “File” menu.  

↗ This will bring up a window in which you can select the 
audio file you want to work with.  

↗ Using this window, navigate to where that file is saved, 
and double---click on its icon to open it.  

↗ Audacity should then open the file, and you can 
continue working with it from there like any other 
recording.  Audacity isn’t able to open all audio formats, 
but it should be able to open WAV, AIFF, and MP3 files. 



Audacity: Editing files

↗ Now that your recording is open, there are probably 
some parts at the beginning and end that you don’t 
need. Let’s trim those off.

↗ Click the Skip to Start button in the toolbar.

↗ With the cursor, click just before the point where you 
started talking

↗ Choose “Edit>Select Track Start to Cursor”

↗ The region before you started talking will be selected.



Editing files

↗ Choose “Edit>Delete.”

↗ The region before you started talking will be 
deleted.

↗ Now you can also delete the blank space at the end 
of your recording—try doing this by just dragging 
your mouse over the area you want to delete.



Increasing the volume

↗ Sometimes our language recordings are too quiet 
even after we carefully adjusted the input levels. If 
this happens, you can use Audacity to make your 
whole recording a little louder.

↗ Use CTRL-A to select the entire recording.

↗ Choose “Effects>Normalize…” then click the OK 
button.

↗ This will adjust the volume of your entire recording.



Saving
a file after editing it

↗ To save your entire recording in Audacity, choose 
“File>Export…”

↗ When saving your file, make sure that the Format 
selected in the bottom selection box is set to WAV 
(Microsoft) signed 16 bit PCM.  

↗ This makes sure that your recording is saved as an 
uncompressed, lossless WAV file, a format that 
virtually all audio programs can use and which 
doesn't throw away any information from the 
original recording.



Saving
a file after editing it

↗ Note: Be careful not to select “Save Project” in the 
File menu: this will produce a set of files that only 
Audacity can read!  

■You can use “Save Project” if you want to 
continue editing later.

↗ Instead, be sure to save your recordings as WAV 
files using the “Export...” option in the File menu, as 
described above.
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Saving just
a part of a recording

↗ Once you have selected the portion of audio you want to 
extract, enter the 'File' menu, then select Export selection....  
Choose a name and location for your audio clip. 

↗ The section of audio that you highlighted should then be 
saved as a separate WAV file, which can then be used 
independently.

↗ Note: Just as before, do not select Save Project in the File 
menu.  Instead, select Export selection..., which will produce 
nice, uncompressed WAV files for later use.



Creating audio clips

↗ To create an audio clip highlight a portion of the recording and 
choose Tracks | Add Label At Selection

↗ Type a name for the label in the box which appears

↗ You can use the sliders to adjust the boundaries of the labeled clip

↗ When you have finished creating clips choose File | Export Multiple



What is SayMore?

↗ SayMore is a Language Documentation Project 
Management software.

↗ Allows you to:

■Track projects and metadata

■Track people

■Do basic transcription and translation

↗ Free download at http://saymore.palaso.org/



What is SayMore?

↗ SayMore is a Language Documentation Project 
Management software.

↗ Free download at http://saymore.palaso.org/

↗ Sample audio clip at 
http://tinyurl.com/atalm2015-sampleclip

↗ Wifi: Renaissance Conference
atalm2015

http://saymore.palaso.org/
http://tinyurl.com/atalm2015-sampleclip
http://tinyurl.com/atalm2015-sampleclip


Creating a project

↗ The first time you open 
SayMore you will be brought
 to an opening window,
 like this:

↗ Let’s create a new project.



Creating a project

↗ Click on the 
“Create new, blank project…”

↗ Give your project a name. 

↗ I’m going to call this one 
“Otomi  demo”

↗ SayMore will create a new project and save it onto your 
computer. 



Project Metadata

↗ The next window is where you will begin to enter 
your metadata. Include as much information as you 
can in each field under About This Project. 



Project Metadata

↗ Notice that on the left hand side of the window 
there are four other types of information you can 
include in the metadata of your project.

↗ Access Protocol: This field allows you to specify how 
the data will be accessed. There are some default 
selections along with the ability to select None (no 
access protocol) or Custom (set up you own access 
protocol for your data).



Project Metadata

↗ Notice that on the left hand side of the window 
there are four other types of information you can 
include in the metadata of your project.

↗ Description Documents: This field allows you to 
upload documents that describe your project and 
data. For example, if one of your recordings involves 
a speaker reading a list of words you could add a 
copy of that document here (we can associate the 
list document with the actual recording later). You 
can also upload your consent forms.



Project Metadata

↗ Notice that on the left hand side of the window 
there are four other types of information you can 
include in the metadata of your project.

↗ Other Documents: This is another location to upload 
documents that don’t seem to fit anywhere else. For 
example, an e-mail conversation about how a 
particular verb is used could be documented and 
archived here.



Project Metadata

↗ Notice that on the left hand side of the window 
there are four other types of information you can 
include in the metadata of your project.

↗ Progress: This field allows you to keep track of how 
much you have done and the general progress you 
have made with your materials.



Adding people
to your project

↗ While creating a new session is really the meat and potatoes of 
our work here, we are going to work with the People section 
first. 

↗ On the top of the main 
window, notice that there 
are three tabs labeled 
Project, Sessions, and 
People. 

↗ Click on the People tab, 
which will change the
 window.



Adding people
to your project

↗ In the bottom left hand corner you will see a button called New click 
on this and it will allow you to create a new “person” in your project. 

↗ After clicking New you 
should notice that at the 
bottom right hand side is a 
set of new fields for you to 
enter information

↗ Please fill in as much 
information as you can here. 



Creating “sessions”

↗ Now we are going to create a session. This is where we 
are going to document our audio and video files and 
create a transcript of what was said. 

↗ A “session” is everything related to a single recording 
event, including 

↗ audio files

↗ transcripts,

↗ metadata, etc. 

↗ We usually need a separate session for each recording.



Creating “sessions”

↗ The first step will be to click the Session tab. This will take 
you to the area where you can add your session.

↗ Just like with adding a person you will 
click New in the bottom
left hand corner. This will 
create a new session.



Creating “sessions”

↗ Now in the bottom right hand corner you will see empty 
metadata fields for describing your recording. Add as 
much information as you know. 



Creating “sessions”

↗ Now in the top right hand corner of the window there is a 
button labeled  +Add Files…, 

■sample clip & transcription at http://tinyurl.com/atalm2015-sampleclip

↗ Click on this and then find where you have your audio
file saved on your computer
or your thumb drive. 
Click on that file and select 
Open. 

↗ This will add that file to 
your session.



Creating “sessions”

↗ Click on the audio file to see information about the 
recording in the bottom right hand part of the window. 

↗ You can click on the Audio tab and listen to the file as well. 



Transcribing

↗ Click on the Start Annotating tab to begin 
transcribing/translating.

↗ Select a Segmentation Method to divide the audio 
into chunks.

↗ The “auto segmenter” works well, and you can 
always make manual changes later. 

■So select “Use auto segmenter” and click Get 
Started…



Transcribing

↗ Once SayMore has segmented your recording, you 
can listen to each clip and transcribe and translate 
it. 

↗ If you want to change where segment boundaries 
are you can click on the Segment link.

■In this new window you can adjust the 
boundaries of the segments to your liking.

↗ You can also export your transcript as plain text or 
other formats.



Saving your work

↗ SayMore automatically saves all of your session, person, 
and project information, to the Documents Folder of your 
computer.

↗ Next time you want to work on your 
project in SayMore, Go to Project > 
Open/Create Session > Browse for Project…



Other
Transcription Tools

● SayMore
○ http://saymore.palaso.org/

● TranscriberAG
○ http://transag.sourceforge.net/

● ELAN
○ http://tla.mpi.nl/tools/tla-tools/elan/

● Create “stand-off” annotation in a separate file 
without altering the original media file.

http://saymore.palaso.org/
http://saymore.palaso.org/
http://transag.sourceforge.net/
http://transag.sourceforge.net/
http://tla.mpi.nl/tools/tla-tools/elan/
http://tla.mpi.nl/tools/tla-tools/elan/


ELAN XML



Mukurtu mobile



What is Mukurtu?

● Mukurtu (MOOK-oo-too) is a grassroots project 
aiming to empower communities to manage, share, 
and exchange their digital heritage in culturally 
relevant and ethically-minded ways. We are 
committed to maintaining an open, community-
driven approach to Mukurtu’s continued 
development. Our first priority is to help build a 
platform that fosters relationships of respect and 
trust.



Mukurtu Mobile 
for language documentation

● Mukurtu Mobile allows the creation of digital 
content using a mobile device (currently 
iPhone/iPad)

● Add images, text, audio, video

● Add descriptive metadata

● Add cultural protocols

● Sync with Mukurtu repository



Mukurtu Mobile
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Lexical database (dictionary) tools

● Toolbox  - www.sil.org/computing/toolbox

● Fieldworks  - fieldworks.sil.org

● Lexique Pro  - www.lexiquepro.com

● Miromaa  -  www.miromaa.org.au

● WeSay  -  wesay.palaso.org

● TshwaneLex  - tshwanedje.com/tshwanelex

● Ensure that the tool is able to export to LIFt XML

http://www.sil.org/computing/toolbox
http://fieldworks.sil.org/
http://www.lexiquepro.com
http://www.miromaa.org.au
http://wesay.palaso.org/
http://tshwanedje.com/tshwanelex/


LexiquePro



LexiquePro text file



Dictionary apps



Where to get more training
● Collaborative Institute on Language Documentation (CoLang)  

www.alaska.edu/colang2016
● Canadian Indigenous Languages and Literacy Development 

Institute (CILLDI)  www.cilldi.ualberta.ca
● Northwest Indian Language Institute (NILI) pages.uoregon.

edu/nwili/ 
● American Indian Language Development Institute (AILDI)  

aildi.arizona.edu
● Indigenous Language Institute (ILI) www.indigenous-

language.org
● Advocates for Indigenous California Language Survival   

www.aicls.org
● National Breath of Life Archival Institute nationalbreathoflife.

org

http://www.alaska.edu/colang2016
http://www.alaska.edu/colang2016
http://www.cilldi.ualberta.ca
http://pages.uoregon.edu/nwili/%20
http://pages.uoregon.edu/nwili/%20
http://pages.uoregon.edu/nwili/%20
http://pages.uoregon.edu/nwili/%20
http://aildi.arizona.edu
http://aildi.arizona.edu
http://www.indigenous-language.org
http://www.indigenous-language.org
http://www.indigenous-language.org
http://www.aicls.org
http://www.aicls.org
http://nationalbreathoflife.org
http://nationalbreathoflife.org
http://nationalbreathoflife.org


Funding for language projects

● Administration for Native Americans

● Documenting Endangered Languages (NSF/NEH)
○ see presentation Saturday at 2:00 pm 

● American Philosophical Society

● Jacobs Fund

● Endangered Language Fund



You guys I want to put this one in 
     your heart, in your mind.
That one day—how many
     recordings I make for you?
Respect, take care.
Don’t say “I lost that recording.”
My words are very strong words,
you gotta keep that recording.

--Ellen Demit

This material is based upon work supported by the National Science 
Foundation under Grants No. OPP-0957136, OPP-1003481, OPP-
1003160, OPP-1317245, Alaska EPSCoR 335863.


